WordPress - Troubleshooting - The button doesn't appear on my website

In this article, you'll learn how to troubleshoot when the Weglot language switcher is not displayed.

First, check if you follow all the integration steps (integration instructions available in the setup category). 

If the button is still not displayed on your website, follow these 3 steps to check:

1) Go to your Weglot settings and click on "Save Changes", even if you already did it in the past

If that doesn't work, you can go ahead and go to the next step. 

2) Check if you excluded a URL page from translations

If so (as shown below), you can either keep the exclusion (the button will never appear on this specific page) or remove the exclusion, and the button will be displayed (don't forget to click on save).

If it does not work, you can go ahead and go to the next step. 

3) Clear your cache

If you're using a cache on the server side (with a plugin such as  https://wp-rocket.me/ or via your hosting provider), then clear it (you should have a clear or empty button to do that). Refresh your website page and check if the button appears.

If not, hard-refresh your website's page (Mac: cmd shift R (lowercase) / PC: ctrl F5) and check back in an incognito window to see if the button appears.

4) Check your word count usage on your Weglot Dashboard

In your Weglot Dashboard, in the Overview section, you can see your current word usage.

If you're on the Free plan, the button will disappear, and Weglot will stop displaying the translations if you reach the 2,000 translated words limit.

After completing these steps, if the language switcher is still not displayed, please get in touch with us at support@weglot.com; we'll be happy to help you out!

Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.

Still need help? Contact Us Contact Us